RFC 755 HISTORIC STANDARDS · NUMBERS REGISTRY · NETWORK PROTOCOLS

Assigned numbers

Updated registry of assigned numbers for network protocols in 1979

On rfc-editor.org ↗
PUBLISHED
May 1979
AUTHORS
J. Postel
STREAM
Legacy
BUILDS ON
RFC 750 — Assigned numbers
OBSOLETED BY
RFC 758 — Assigned numbers
NETWORK NUMBERS ASSIGNED (1979)
26
LINK NUMBERS
0-255
SOCKET RANGES
4 (standard, host-specific, reserved, experimental)
DOI
10.17487/RFC0755

RFC text

Original text · RFC Editor View on rfc-editor.org ↗
Network Working Group                                          J. Postel
Request for Comments: 755                                        USC-ISI
IEN: 93                                                       3 May 1979

Obsoletes: 750,
739, 604, 503, 433, 349



                            ASSIGNED NUMBERS




This Network Working Group Request for Comments documents the currently
assigned values from several series of numbers used in network protocol
implementations.  This RFC will be updated periodically, and in any case
current information can be obtained from Jon Postel. The assignment of
numbers is also handled by Jon.  If you are developing a protocol or
application that will require the use of a link, socket, etc. please
contact Jon to receive a number assignment.

   Jon Postel
   USC - Information Sciences Institute
   4676 Admiralty Way
   Marina del Rey, California  90291

   phone: (213) 822-1511

   ARPANET mail: POSTEL@ISIB

Most of the protocols mentioned here are documented in the RFC series of
notes. The more prominent and more generally used are documented in the
Protocol Handbook [1] prepared by the Network Information Center (NIC).
In the lists that follow a bracketed number, e.g. [1], off to the right
of the page indicates a reference for the listed protocol.

IEN 93                                                  Assigned Numbers
Link Numbers



                         ASSIGNED LINK NUMBERS

   The word "link" here refers to a field in the original ARPANET
   Host/IMP interface leader.  The link was originally defined as an 8
   bit field.  Some time after the ARPANET Host-to-Host (AHHP) protocol
   was defined and, by now, some time ago the definition of this field
   was changed to "Message-ID" and the length to 12 bits. The name link
   now refers to the high order 8 bits of this 12 bit message-id field.
   The low order 4 bits of the message-id field are to be zero unless
   specifically specified otherwise for the particular protocol used on
   that link.  The Host/IMP interface is defined in BBN report 1822 [2].

   Link Assignments:

      Decimal   Octal     Description                         References
      -------   -----     -----------                         ----------
      0         0         AHHP Control Messages                    [1,3]
      1         1         Reserved
      2-71      2-107     AHHP Regular Messages                    [1,3]
      72-151    110-227   Reserved
      152       230       PARC Universal Protocol
      153       231       TIP Status Reporting
      154       232       TIP Accounting
      155-158   233-236   Internet Protocol             [35,36,42,43,44]
      159-191   237-277   Measurements                              [28]
      192-195   300-303   Message Switching Protocol               [4,5]
      196-255   304-377   Experimental Protocols
      224-255   340-377   NVP                                     [1,39]

IEN 93                                                  Assigned Numbers
Socket Numbers



                        ASSIGNED SOCKET NUMBERS

   Sockets are used in the AHHP [1,3] to name the ends of logical
   connections which carry long term conversations.  For the purpose of
   providing services to all callers an Initial Connection Procedure ICP
   [1,34] is used between the user process and the server process.  This
   list specifies the socket used by the server process as its contact
   socket.

   Socket Assignments:

      General Assignments:

         Decimal   Octal     Description
         -------   -----     -----------
         0-63      0-77      Network Wide Standard Function
         64-127    100-177   Hosts Specific Functions
         128-223   200-337   Reserved for Future Use
         224-255   340-377   Any Experimental Function

      Specific Assignments:

         Network Standard Functions

         Decimal   Octal     Description                      References
         -------   -----     -----------                      ----------
         1         1         Old Telnet                              [6]
         3         3         Old File Transfer                   [7,8,9]
         5         5         Remote Job Entry                     [1,10]
         7         7         Echo                                   [11]
         9         11        Discard                                [12]
         11        13        Who is on or SYSTAT
         13        15        Date and Time
         15        17        Who is up or NETSTAT
         17        21        Short Text Message
         19        23        Character generator or TTYTST          [13]
         21        25        New File Transfer                 [1,14,15]
         23        27        New Telnet                        [1,16,17]
         25        31        Distributed Programming System      [18,19]
         27        33        NSW User System w/COMPASS FE           [20]
         29        35        MSG-3 ICP                              [21]
         31        37        MSG-3 Authentication                   [21]
         33        41        DPS ICP                             [18,19]
         35        43        IO Station Spooler
         37        45        Time Server                          [1,22]
         39        47        NSW User System w/SRI FE               [20]

IEN 93                                                  Assigned Numbers
Socket Numbers



         41        51        Graphics                             [1,26]
         42-63     52-77     unassigned

         Host Specific Functions

         Decimal   Octal     Description                      References
         -------   -----     -----------                      ----------
         65        101       Speech Data Base at LL-TX-2            [23]
         67        103       Datacomputer at CCA                    [24]
         69        105       CPYNET
         71        107       NETRJS (EBCDIC) at UCLA-CCN          [1,25]
         73        111       NETRJS (ASCII-68) at UCLA-CCN        [1,25]
         75        113       NETRJS (ASCII-63) at UCLA-CCN        [1,25]
         77        115       any private RJE server
         79        117       Name or Finger                       [1,40]
         81        121       Network BSYS
         83        123       MIT ML Device
         85        125       MIT ML Device
         86-94     126-136   unassigned
         95        137       SUPDUP                                 [33]
         97        141       Datacomputer Status
         98-127    142-136   unassigned

         Reserved for Future Use

         Decimal   Octal     Description                      References
         -------   -----     -----------                      ----------
         128-223   200-337   reserved

         Experimental Functions

         Decimal   Octal     Description                      References
         -------   -----     -----------                      ----------
         224-231   340-347   unassigned
         232-237   350-355   Authorized Mailer at BBN
         239       357       unassigned
         241       361       NCP Measurement                     [27,28]
         243       363       Survey Measurement               [28,29,30]
         245       365       LINK                                   [31]
         247       367       TIPSRV
         249-255   371-377   RSEXEC                              [31,32]

IEN 93                                                  Assigned Numbers
Network Numbers



                        ASSIGNED NETWORK NUMBERS

   This list of network numbers is used in the internetwork protocols
   now under development, the field is 8 bits in size.

   Assigned Network Numbers

      Decimal   Octal  Name        Network                    References
      -------   -----  ----        -------                    ----------
            0       0              Reserved
            1       1  BBN-PR      BBN Packet Radio Network
            2       2  SF-PR-1     SF Bay Area Packet Radio Network (1)
            3       3  BBN-RCC     BBN RCC Network
            4       4  SATNET      Atlantic Satellite Network
            5       5  SILL-PR     Ft. Sill Packet Radio Network
            6       6  SF-PR-2     SF Bay Area Packet Radio Network (2)
            7       7  CHAOS       CHAOS Network
            8      10  BBN-SAT-TEST  BBN SATNET Test Network
            9      11  BRAGG-PR    Ft. Bragg Packet Radio Network
           10      12  ARPANET     ARPANET                         [1,2]
           11      13  UCLNET      University College London Network
           12      14  CYCLADES    CYCLADES
           13      15  NPLNET      National Physical Laboratory
           14      16  TELENET     TELENET
           15      17  EPSS        British Post Office EPSS
           16      20  DATAPAC     DATAPAC
           17      21  TRANSPAC    TRANSPAC
           18      22  LCSNET      LCS Network                   [37,38]
           19      23  TYMNET      TYMNET
           20      24  DC-PR       Washington D.C. Packet Radio Network
           21      25  EDN         DCEC EDN
           22      26  DIALNET     DIALNET                       [47,48]
           23      27  MITREK      MITREK Cable Network
           24      30  BBN-LOCAL   BBN Local Network
           25      31  RSRE-PPSN   RSRE / PPSN
       26-254  32-376              Unassigned
          255     377              Reserved

IEN 93                                                  Assigned Numbers
Internet Message Versions



                   ASSIGNED INTERNET MESSAGE VERSIONS

   In the internetwork protocols there is a field to identify the
   version of the internetwork general protocol.  This field is 4 bits
   in size.

   Assigned Internet Message Versions

      Decimal   Octal      Version                            References
      -------   -----      -------                            ----------
          0      0         March 1977 version                       [35]
          1      1         January 1978 version                     [36]
          2      2         February 1978 version A                  [42]
          3      3         February 1978 version B                  [43]
          4      4         February 1979 version 4                  [44]
       5-14   5-16         Unassigned
         15     17         Reserved

IEN 93                                                  Assigned Numbers
Internet Protocol Numbers



                   ASSIGNED INTERNET PROTOCOL NUMBERS

   In the internet protocol (IN) [44] there is a field to identify the
   the next level protocol.  This field is 8 bits in size.  This field
   is called Protocol in the IN header.

   Assigned Internet Protocol Numbers

      Decimal   Octal      Protocol Numbers                   References
      -------   -----      ----------------                   ----------
           0      0         Reserved
           1      1         raw internet datagrams                  [44]
           2      2         TCP-3                                   [36]
           3      3         Gateway-to-Gateway                      [49]
           4      4         Gateway Monitoring Message              [41]
           5      5         TCP-3.1                                 [45]
           6      6         TCP-4                                   [46]
           7      7         UCL
           8     10         DSP                                  [37,38]
           9     11         Secure
          10     12         TCP-2                                   [35]
       11-12  13-14         Unassigned
          13     15         Pluribus
          14     16         Telenet
          15     17         XNET
          16     20         Chaos
          17     21         UDP                                     [50]
          18     22         Multiplexing                            [51]
      19-254 23-376         Unassigned
         255    377         Reserved

IEN 93                                                  Assigned Numbers
Internet Message Types



                    ASSIGNED INTERNET MESSAGE TYPES

   In the March 1977 internetwork protocol [35] there is a field to
   identify the type of the message.  This field is 4 bits in size.

   Assigned Internet Message Types

      Decimal   Octal      Type                               References
      -------   -----      ----                               ----------
          0      0         Raw Internet Packet
          1      1         TCP-2                                    [35]
          2      2         Secure
          3      3         Gateway
          4      4         Measurement
          5      5         DSP                                   [37,38]
          6      6         UCL
       7-12   7-14         Reserved
         13     15         Pluribus
         14     16         Telenet
         15     17         Xnet

IEN 93                                                  Assigned Numbers
References



                               REFERENCES

   [1]    Feinler, E. and J. Postel, eds., "ARPANET Protocol Handbook,"
          NIC 7104, for the Defense Communications Agency by SRI
          International, Menlo Park, California, Revised January 1978.

   [2]    BBN, "Specifications for the Interconnection of a Host and an
          IMP," Report 1822, Bolt Beranek and Newman, Cambridge,
          Massachusetts, January 1976.

   [3]    McKenzie,A. "Host/Host Protocol for the ARPA Network,"
          NIC 8246, January 1972.  Also in [1].

   [4]    Walden, D. " A System for Interprocess Communication in a
          Resource Sharing Network," RFC 62, NIC 4962, 3 August 1970.
          Also published in Communications of the ACM, volume 15,
          number 4, April 1972.

   [5]    Bressler, B. "A Proposed Experiment with a Message Switching
          Protocol," RFC 333, NIC 9926, 15 May 72.

   [6]    Postel, J. "Telnet Protocol," RFC 318, NIC 9348, 3 April 1972.

   [7]    McKenzie, A. "File Transfer Protocol," RFC 454, NIC 14333,
          16 February 1973.

   [8]    Clements, R. "FTPSRV -- Extensions for Tenex Paged Files,"
          RFC 683, NIC 32251, 3 April 1975.  Also in [1].

   [9]    Harvey, B. "One More Try on the FTP," RFC 691, NIC 32700,
          6 June 1975.

   [10]   Bressler, B. "Remote Job Entry Protocol,"  RFC 407, NIC 12112,
          16 October 72.  Also in [1].

   [11]   Postel, J. "Echo Process,"  RFC 347, NIC 10426, 30 May 1972.

   [12]   Postel, J. "Discard Process,"  RFC 348, NIC 10427,
          30 May 1972.

   [13]   Postel, J. "Character Generator Process," RFC 429, NIC 13281,
          12 December 1972.

   [14]   Neigus, N. "File Transfer Protocol," RFC 542, NIC 17759,
          12 July 1973.  Also in [1].

IEN 93                                                  Assigned Numbers
References



   [15]   Postel, J. "Revised FTP Reply Codes," RFC 640, NIC 30843,
          5 June 1974.  Also in [1].

   [16]   McKenzie, A. "Telnet Protocol Specification," NIC 18639,
          August 1973.  Also in [1].

   [17]   McKenzie, A. "Telnet Option Specification," NIC 18640,
          August 1973.  Also in [1].

   [18]   White, J. "A High Level Framework for Network-Based Resource
          Sharing," RFC 707, NIC 34263, 14 January 1976. Also in NCC
          Proceedings, AFIPS, June 1976.

   [19]   White, J. "Elements of a Distributed Programming System,"
          RFC 708, NIC 34353, 28 January 1976.

   [20]   COMPASS. "Semi-Annual Technical Report," CADD-7603-0411,
          Massachusetts Computer Associates, 4 March 1976. Also as,
          "National Software Works, Status Report No. 1,"
          RADC-TR-76-276, Volume 1, September 1976. And COMPASS. "Second
          Semi-Annual Report," CADD-7608-1611, Massachusetts Computer
          Associates, 16 August 1976.

   [21]   NSW Protocol Committee, "MSG: The Interprocess Communication
          Facility for the National Software Works," CADD-7612-2411,
          Massachusetts Computer Associates, BBN 3237, Bolt Beranek and
          Newman, Revised 24 December 1976.

   [22]   Harrenstien, K. "Time Server," RFC 738, NIC 42218,
          31 October 1977.  Also in [1].

   [23]   Armenti, A., D. Hall, and A. Stone. "Lincoln Speech Data
          Facility," SUR Note 37, NIC 10917, 14 July 1972.

   [24]   CCA, "Datacomputer Version 1 User Manual," Computer
          Corporation of America, August 1975.

   [25]   Braden, R. "NETRJS Protocol," RFC 740, NIC 42423,
          22 November 1977.  Also in [1].

   [26]   Sproull, R, and E. Thomas. "A Networks Graphics Protocol,"
          NIC 24308, 16 August 1974.  Also in [1].

   [27]   Cerf, V., "NCP Statistics," RFC 388, NIC 11360,
          23 August 1972.

IEN 93                                                  Assigned Numbers
References



   [28]   Cerf, V., "Formation of a Network Measurement Group (NMG),"
          RFC 323, NIC 9630, 23 March 1972.

   [29]   Bhushan, A., "A Report on the Survey Project," RFC 530,
          NIC 17375, 22 June 1973.

   [30]   Cantor, D., "Storing Network Survey Data at the Datacomputer,"
          RFC 565, NIC 18777, 28 August 1973.

   [31]   Bressler, R., "Inter-Entity Communication -- An Experiment,"
          RFC 441, NIC 13773, 19 January 1973.

   [32]   Thomas, R. "A Resource Sharing Executive for the ARPANET,"
          AFIPS Conference Proceedings, 42:155-163, NCC, 1973.

   [33]   Crispin, M. "SUPDUP Protocol," RFC 734, NIC 41953,
          7 October 1977.  Also in [1].

   [34]   Postel, J. "Official Initial Connection Protocol," NIC 7101,
          11 June 1971.  Also in [1].

   [35]   Cerf, V. "Specification of Internet Transmission Control
          Program -- TCP (version 2)," March 1977.

   [36]   Cerf, V. and J. Postel, "Specification of Internetwork
          Transmission Control Program -- TCP Version 3,"
          USC-Information Sciences Institute, January 1978.

   [37]   Reed, D. "Protocols for the LCS Network," Local Network Note
          3, Laboratory for Computer Science, MIT, 29 November 1976.

   [38]   Clark, D. "Revision of DSP Specification," Local Network Note
          9, Laboratory for Computer Science, MIT, 17 June 1977.

   [39]   Cohen, D. "Specifications for the Network Voice Protocol
          (NVP)," NSC Note 68, 29 January 1976.  Also as USC-Information
          Sciences Institute RR-75-39, March 1976, and as RFC 741,
          NIC 42444, 22 November 1977.  Also in [1].

   [40]   Harrenstien, K. "Name/Finger," RFC 742, NIC 42758,
          30 December 1977.  Also in [1].

   [41]   Cole, J. "Gateway Monitoring Messages," BBN, 1 February 1978.

   [42]   Postel, J. "Draft Internetwork Protocol Specification --
          Version 2," USC-Information Sciences Institute, February 1978.

IEN 93                                                  Assigned Numbers
References



   [43]   Cerf, V. "A Proposed New Internet Header Format," Advanced
          Research Projects Agency, IEN 26, 14 February 1978.

   [44]   Postel, J. "Internet Datagram Protocol -- Version 4," IEN-80,
          USC-Information Sciences Institute, February 1979.

   [45]   Cerf, V. "A Proposal for TCP Version 3.1 Header Format,"
          Advanced Research Projects Agency, IEN 26, 14 February 1978.

   [46]   Postel, J., "Transmission Control Protocol -- Version 4,"
          IEN-81, USC-Information Sciences Institute, February 1979.

   [47]   McCarthy, J. and L. Earnest, "DIALNET," Stanford University
          Artificial Intelligence Laboratory, Undated.

   [48]   Crispin, M. and I. Zabala, "DIALNET Protocols," Stanford
          University Artificial Intelligence Laboratory, July 1978.

   [49]   Strazisar, V, and R. Perlman, "Gateway Routing, An
          Implementation Specification," IEN-30, Bolt Berenak and
          Newman, April 1978.

   [50]   Postel, J., "User Datagram Protocol," IEN-88, USC-Information
          Sciences Institute, May 1979.

   [51]   Cohen, D. and J. Postel, "Multiplexing Protocol," IEN-90,
          USC-Information Sciences Institute, May 1979.

AI ELI5

On this page
PROBLEMProtocols and network numbers continued to be assigned; the 1978 registry (RFC 750) needed updates to remain current.
MECHANISMJon Postel issued an updated assigned-numbers registry covering link numbers, socket numbers, network numbers (now with 26 assignments including DIALNET and MITREK), IP versions, and protocol formats with new entries for Gateway-to-Gateway and other protocols.
CONTINUED NUMBER MANAGEMENTThe registry continued to serve as the authoritative source for protocol numbers and assignments. It was again replaced the following year by RFC 758.

§1Maintaining the Registry

RFC 755 is the 1979 update to the assigned numbers registry. Like RFC 750, it documents all numbers assigned in ARPANET and internet protocols: link numbers, socket numbers, network addresses, protocol versions, and protocol numbers. Jon Postel continued to manage assignments and maintain the registry.

This version consolidates six earlier RFCs (750, 739, 604, 503, 433, 349) into one comprehensive list, maintaining the tradition of keeping a single authoritative source as the network and its protocols evolved.

The list was updated again a year later with new networks and protocols that had been added or discovered.

§2Updated Assignments

The network numbers section grew from 22 to 26 assignments, adding DIALNET (22), MITREK Cable Network (23), BBN Local Network (24), and RSRE/PPSN (25). Socket and link assignments remained largely the same, with some additions to the protocol format identifiers (now including Gateway-to-Gateway on protocol 3, and more internet protocols).

The IP protocol numbers section expanded to include new variants tested and deployed in the late 1970s. The socket ranges and their meanings (0–63 standard, 64–127 host-specific, 128–223 reserved, 224–255 experimental) remained consistent with the 1978 version.

More networks and protocols got added to the lists. The basic structure stayed the same, but the registries grew as the internet expanded.

§3Periodic Updates

RFC 755 notes that the registry would continue to be updated periodically, with current information always available from Jon Postel. The RFC maintains the same reference format as RFC 750, citing the Protocol Handbook and other RFCs for detailed specifications.

RFC 755 is Historic and was replaced by RFC 758 in 1980, which continued the annual or biennial update cycle. This pattern of maintained, authoritative registries eventually evolved into the modern IANA system.

This was just the latest version. Jon would keep updating it as more protocols got assigned numbers. The next year there would be another update.

§4References