RFC 739 HISTORIC META · REGISTRY

Assigned numbers

A registry of protocol numbers and reserved network addresses

On rfc-editor.org ↗
PUBLISHED
November 1977
AUTHORS
J. Postel
STREAM
Legacy
BUILDS ON
RFC 503 — Socket number list, RFC 604 — Assigned link numbers
OBSOLETED BY
RFC 750 — Assigned numbers
LINK NUMBER FIELD
8 bits (high order of 12-bit message-id)
SOCKET RANGES
0-255 (four categories)
NETWORK NUMBER FIELD
8 bits
INTERNET MESSAGE VERSION FIELD
4 bits
DOI
10.17487/RFC0739

RFC text

Original text · RFC Editor View on rfc-editor.org ↗
NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers



Network Working Group                                          J. Postel
Request for Comments: 739                                        USC-ISI
NIC: 42341                                              11 November 1977



                            ASSIGNED NUMBERS




This Network Working Group Request for Comments documents the currently
assigned values from several series of numbers used in network protocol
implementations.  This RFC will be updated periodically, and in any case
current information can be obtained from Jon Postel. The assignment of
numbers is also handled by Jon.  If you are developing a protocol or
application that will require the use of a link, socket, etc. please
contact Jon to receive a number assignment.

   Jon Postel
   USC - Information Sciences Institute
   4676 Admiralty Way
   Marina del Rey, California  90291

   phone: (213) 822-1511

   ARPANET mail: POSTEL@ISIB

Most of the protocols mentioned here are documented in the RFC series of
notes. The more prominent and more generally used are documented in the
Protocol Handbook [1] prepared by the Network Information Center (NIC).
In the lists that follow a bracketed number, e.g. [1], off to the right
of the page indicates a reference to the protocol assigned that number.

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
Assigned Link Numbers



                         ASSIGNED LINK NUMBERS

   The word "link" here refers to a field in the original ARPANET
   Host/IMP interface leader.  The link was originally defined as an 8
   bit field.  Some time after the ARPANET Host-to-Host (AHHP) protocol
   was defined and, by now, some time ago the definition of this field
   was changed to "Message-ID" and the length to 12 bits. The name link
   now refers to the high order 8 bits of this 12 bit message-id field.
   The low order 4 bits of the message-id field are to be zero unless
   specifically specified otherwise for the particular protocol used on
   that link.  The Host/IMP interface is defined in BBN report 1822 [2].

   Link Assignments:

      Decimal   Octal     Description                         References
      -------   -----     -----------                         ----------
      0         0         AHHP Control Messages                    [1,3]
      1         1         Reserved
      2-71      2-107     AHHP Regular Messages                    [1,3]
      72-151    110-227   Reserved
      152       230       PARC Universal Protocol
      153       231       TIP Status Reporting
      154       232       TIP Accounting
      155-158   233-236   Internet Protocol                      [35,36]
      159-191   237-277   Measurements                              [28]
      192-195   300-303   Message Switching Protocol               [4,5]
      196-255   304-377   Experimental Protocols

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
Assigned Socket Numbers



                        ASSIGNED SOCKET NUMBERS

   Sockets are used in the AHHP [1,3] to name the ends of logical
   connections which carry long term conversations.  For the purpose of
   providing services to all callers an Initial Connection Procedure ICP
   [1,34] is used between the user process and the server process.  This
   list specifies the socket used by the server process as its contact
   socket.

   Socket Assignments:

      General Assignments:

         Decimal   Octal     Description
         -------   -----     -----------
         0-63      0-77      Network Wide Standard Function
         64-127    100-177   Hosts Specific Functions
         128-223   200-337   Reserved for Future Use
         224-255   340-377   Any Experimental Function

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
Assigned Socket Numbers



      Specific Assignments:

         Decimal   Octal     Description                      References
         -------   -----     -----------                      ----------
         Network Standard Functions
         1         1         Old Telnet                              [6]
         3         3         Old File Transfer                   [7,8,9]
         5         5         Remote Job Entry                       [10]
         7         7         Echo                                   [11]
         9         11        Discard                                [12]
         11        13        Who is on or SYSTAT
         13        15        Date and Time
         15        17        Who is up or NETSTAT
         17        21        Short Text Message
         19        23        Character generator or TTYTST          [13]
         21        25        New File Transfer                 [1,14,15]
         23        27        New Telnet                        [1,16,17]
         25        31        Distributed Programming System      [18,19]
         27        33        NSW User System w/COMPASS FE           [20]
         29        35        MSG-3 ICP                              [21]
         31        37        MSG-3 Authentication                   [21]
         33        41        DPS ICP                             [18,19]
         35        43        IO Station Spooler
         37        45        Time Server                            [22]
         39        47        NSW User System w/SRI FE               [20]
         Host Specific Functions
         65        101       Speech Data Base at LL-TX-2            [23]
         67        103       Datacomputer at CCA                    [24]
         69        105       CPYNET
         71        107       NETRJS (EBCDIC) at UCLA-CCN            [25]
         73        111       NETRJS (ASCII) at UCLA-CCN             [25]
         75        113       NETRJS (TTY) at UCLA-CCN               [25]
         77        115       any private RJE server
         79        117       Finger
         81        121       Network BSYS
         95        137       SUPDUP                                 [33]
         Experimental Functions
         229       345       Garlick's Debugger
         232-237   350-355   Authorized Mailer at BBN
         239       357       Graphics                             [1,26]
         241       361       NCP Measurement                     [27,28]
         243       363       Survey Measurement               [28,29,30]
         245       365       LINK                                   [31]
         247       367       TIPSRV
         249-255   371-377   RSEXEC                              [31,32]

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
Assigned Network Numbers



                        ASSIGNED NETWORK NUMBERS

   This list of network numbers is used in the internetwork protocols
   now under development, the field is 8 bits in size.

   Assigned Network Numbers

      Decimal   Octal      Network
      -------   -----      -------
            0       0      Reserved
            1       1      BBN Packet Radio Network
            2       2      SF Bay Area Packet Radio Network (1)
            3       3      BBN RCC Network
            4       4      Atlantic Satellite Network
            5       5      Washington D.C. Packet Radio Network
            6       6      SF Bay Area Packet Radio Network (2)
          7-9    7-11      Not assigned
           10      12      ARPANET
           11      13      University College London Network
           12      14      CYCLADES
           13      15      National Physical Laboratory
           14      16      TELENET
           15      17      British Post Office EPSS
           16      20      DATAPAC
           17      21      TRANSPAC
           18      22      LCS Network
           19      23      TYMNET
       20-254  24-376      Unassigned
          255     377      Reserved

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
Assigned Internet Message Versions



                   ASSIGNED INTERNET MESSAGE VERSIONS

   In the internetwork protocols there is a field to identify the
   version of the internetwork general protocol.  This field is 4 bits
   in size.

   Assigned Internet Message Versions

      Decimal   Octal      Version                            References
      -------   -----      -------                            ----------
          0      0         Old                                      [35]
          1      1         Current                                  [36]
       2-14   2-16         Unassigned
         15     17         Reserved

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
Assigned Internet Message Formats



                   ASSIGNED INTERNET MESSAGE FORMATS

   In the internetwork protocols there is a field to identify the format
   of the host level specific protocol.  This field is 8 bits in size.

   Assigned Internet Message Formats

      Decimal   Octal      Format                             References
      -------   -----      ------                             ----------
          0      0         Reserved
          1      1         raw internet
          2      2         TCP-3                                    [36]
          3      3         DSP                                   [37,38]
      2-254  2-376         Unassigned
        255    377         Reserved

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
Assigned Internet Message Types



                    ASSIGNED INTERNET MESSAGE TYPES

   In the internetwork old protocol there is a field to identify the
   type of the message.  This field is 4 bits in size.

   Assigned Internet Message Types

      Decimal   Octal      Type
      -------   -----      ----
          0      0         Escape
          1      1         TCP-2
          2      2         Secure
          3      3         Gateway
          4      4         Measurement
          5      5         DSP
          6      6         UCL
       7-12   7-14         Reserved
         13     15         Pluribus
         14     16         Telenet
         15     17         Xnet

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
References



                               REFERENCES

   [1]    Feinler, E. "ARPANET Protocol Handbook," NIC 7104, Defense
          Communications Agency, 1 April 1976.

   [2]    BBN, "Specifications for the Interconnection of a Host and an
          IMP," Report 1822, Bolt Beranek and Newman, Cambridge,
          Massachusetts, January 1976.

   [3]    McKenzie,A. "Host/Host Protocol for the ARPA Network," NIC
          8246, January 1972.

   [4]    Walden, D. "A System for Interrprocess Communication in a
          Resource Sharing Computer Network," RFC 62, NIC 4962,
          3-Aug-70. Also published in Communications of the ACM volume
          15, number 4, April 1972.

   [5]    Bressler, B. "A Proposed Experiment with a Message Switching
          Protocol," RFC 333, NIC 9926, 15-May-72.

   [6]    Postel, J. "Telnet Protocol," RFC 318, NIC 9348, 3-April-72.

   [7]    McKenzie, A. "File Transfer Protocol," NIC 14333, RFC 454,
          16-Feb-73.

   [8]    Clements, R. "FTPSRV -- Extensions for Tenex Paged Files," RFC
          683, NIC 32251, 3-April-75.

   [9]    Harvey, B. "One More Try on the FTP," RFC 691, NIC 32700,
          6-Jun-75.

   [10]   Bressler, B. "Remote Job Entry Protocol,"  RFC 407, NIC 12112,
          16-Oct-72.

   [11]   Postel, J. "Echo Process,"  RFC 347, NIC 10426, 30-May-72.

   [12]   Postel, J. "Discard Process,"  RFC 348, NIC 10427, 30-May-72.

   [13]   Postel, J. "Character Generator Process," RFC 429, NIC 13281,
          12-Dec-72.

   [14]   Neigus, N. "File Transfer Protocol," NIC 17759 RFC 542
          12-July-73.

   [15]   Postel, J. "Revised FTP Reply Codes," NIC 30843 RFC 640
          5-June-74.

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
References



   [16]   McKenzie, A. "Telnet Protocol Specifications," NIC 18639,
          August 1973.

   [17]   McKenzie, A. "Telnet Option Specification," NIC 18640, August
          1973.

   [18]   White, J. "A High Level Framework for Network-Based Resource
          Sharing," RFC 707, NIC 34263, 14 January 1976. Also in NCC
          Proceedings, AFIPS, June 1976.

   [19]   White, J. "Elements of a Distributed Programming System," RFC
          708, NIC 34353, 28 January 1976.

   [20]   COMPASS. "Semi-Annual Technical Report," CADD-7603-0411,
          Massachusetts Computer Associates, 4 March 1976. Also as,
          "National Software Works, Status Report No. 1,"
          RADC-TR-76-276, Volume 1, September 1976. and COMPASS. "Second
          Semi-Annual Report," CADD-7608-1611, Massachusetts Computer
          Associates, 16 August 1976.

   [21]   NSW Protocol Committee, "MSG: The Interprocess Communication
          Facility for the National Software Works," CADD-7612-2411,
          Massachusetts Computer Associates, BBN 3237, Bolt Beranek and
          Newman, Revised 24 December 1976.

   [22]   Harrenstien, K. "Time Server," RFC 738, NIC 42218, 31-Oct-77.

   [23]   Armenti, A., D. Hall, and A. Stone. "Lincoln Speech Data
          Facility," SUR Note 37, NIC 10917, 14 July 1972.

   [24]   CCA, "Datacomputer Version 1 User Manual," Computer
          Corporation of America, August 1975.

   [25]   Braden, R. "Interim NETRJS Specification," RFC 189, NIC 7133,
          15-July-71.

   [26]   Sproull, R, and E. Thomas. "A Networks Graphics Protocol," NIC
          24308, 16-Aug-74.

   [27]   Cerf, V., "NCP Statistics," RFC 388, NIC 11360, 23 August
          1972.

   [28]   Cerf, V., "Formation of a Network Measurement Group (NMG),"
          RFC 323, NIC 9630, 23 March 1972.

NWG/RFC# 739                                         JBP 11 Nov 77 42341
Assigned Numbers
References



   [29]   Bhushan, A., "A Report on the Survey Project," RFC 530, NIC
          17375, 22 June 1973.

   [30]   Cantor, D., "Storing Network Survey Data at the Datacomputer,"
          RFC 565, NIC 18777, 28 August 1973.

   [31]   Bressler, R., "Inter-Entity Communication -- An Experiment,"
          RFC 441, NIC 13773, 19 January 1973.

   [32]   Thomas, R. "A Resource Sharing Executive for the ARPANET,"
          AFIPS Conference Proceedings, 42:155-163, NCC, 1973.

   [33]   Crispin, M. "SUPDUP Protocol," RFC 734, NIC 41953, 7 October
          1977.

   [34]   Postel, J. "Official Initial Connection Protocol," NIC 7101,
          11 June 1971.

   [35]   Cerf, V. "Specification of Internet Transmission Control
          Program -- TCP (version 2)," March 1977.

   [36]   Cerf, V. and J. Postel, "Specification of Internet
          Transmission Control Program -- TCP-3," November 1977.

   [37]   Reed, D. "Protocols for the LCS Network," Local Network Note
          3, Laboratory for Computer Science, MIT, 29 November 1976.

   [38]   Clark, D. "Revision of DSP Specification," Local Network Note
          9, Laboratory for Computer Science, MIT, 17 June 1977.

AI ELI5

On this page
PROBLEMAs the ARPANET and early internet grew, protocols and applications needed unique identifiers for links, sockets, networks, and message types to avoid conflicts.
MECHANISMRFC 739 publishes a definitive list of all assigned numbers across multiple categories: ARPANET link assignments, socket assignments for standard functions and experimental uses, network numbers for interconnected networks, internet message versions and formats, and message types.
PROTOCOL NUMBER REGISTRYThis registry provided a central source of truth, preventing conflicts and allowing independent implementations to interoperate. It was kept current periodically and replaced by RFC 750.

§1Purpose and Scope

RFC 739 documents the currently assigned values from several series of numbers used in network protocol implementations. The RFC notes that it will be updated periodically, and current assignments can be obtained from Jon Postel at USC-ISI, who also handles new assignments. Developers building protocols or applications requiring link numbers, socket numbers, network numbers, or other standardized identifiers must contact Postel to receive assignments and avoid conflicts.

The network is growing and needs to organize which numbers mean what. This list says who is in charge of giving out numbers and what each one is used for.

§2Link, Socket and Network Numbers

The RFC assigns links (which refer to an 8-bit field in the ARPANET Host/IMP interface leader, now part of a 12-bit message-id) in ranges for different uses: AHHP control messages, regular messages, reserved ranges, experimental protocols and specialized services like PARC protocols and TIP (Terminal IMP) reporting. Socket numbers are assigned for network-wide standard functions (0-63), host-specific functions (64-127), reserved ranges (128-223), and experimental uses (224-255). Network numbers identify different physical networks in the growing internet, including the ARPANET, various packet radio networks, CYCLADES, TELENET and others.

Links, sockets and networks each get number ranges. Some numbers are for standard things like file transfer, others are for experiments, and some are reserved for later.

§3Message Versions and Types

The RFC specifies a 4-bit field identifying the version of the internet protocol (current version is 1, with 0 being older and 2-14 unassigned), and an 8-bit field identifying the format of the host-level protocol (raw internet, TCP-3, and DSP among the early formats). A separate 4-bit message type field distinguishes between different kinds of messages: escape, TCP-2, secure, gateway, measurement, DSP, UCL, and reserved types.

Messages need to say what version they use and what kind they are, so computers know how to read them.

§4References

[1]Feinler, E. "ARPANET Protocol Handbook," NIC 7104, April 1976.
[2]BBN, "Specifications for the Interconnection of a Host and an IMP," Report 1822, January 1976.