RFC 570 UNKNOWN TERMINAL · MAPPING · INTERFACE

Experimental input mapping between NVT ASCII and UCSB On Line System

Mapping network terminal keys to a specialized online system

On rfc-editor.org ↗
PUBLISHED
October 1973
AUTHORS
J.R. Pickens
STREAM
Legacy
OLS KEYBOARD KEYS
168
ASCII CHARACTERS
128
ONE-TO-ONE MAPPINGS
~80 keys
ESCAPE PREFIX
ESC character
DOI
10.17487/RFC0570

RFC text

Contents
Original text · RFC Editor View on rfc-editor.org ↗

This text was converted from the RFC Editor's PDF edition and may contain conversion errors; the layout is approximate. The PDF is the reference copy.

RFC #570Q
NIC 18973
UPDATES:
OBSOLETES:
REFERENCES :

RECEIVED AT NIC NOVEMBER 28, 1973.

RFC 216
None
RFC 216, RFC 398

EXPERIMENTAL INPUT MAPPING

BETWEEN

NVT ASCII AND UCSB ONLINE SYSTEM

30 October 1973

John R. Pickens

Computer Systems Lab
University of California
Santa Barbara

II.
III.

Iv.

vI.

Contents

Motivation . . . . . . . ¢ 4 . . . .
Overview . . ¢ o ¢ ¢ o 4 o o o o o o
Effects on Previous Specification .
Details .+ v ¢ ¢« v ¢ ¢ ¢ & o o o o

A. Details of One-to-One Mapping
B. Details of Two-to~-One Mapping .

New or Revised SERVER TELNET Options

A. OPERATOR/ALPHABET Option . . . .
B. SHIFT/UNSHIFT Option . . . . . .
C. INTERPRETLF/IGNORELF Option . .

Conclusions and Suggestions for Easy

Figures

Figure 1. OLS Keyboard . . . . « ¢« « o« &

Figure 2. One-to-One Mappings . . . . . .

Figure 3. One-to-One Operator Mode Mappings, Expanded

Figure 4.

Operator Mode Mappings. . . . .

Figure 5. Two-to-One Mappings . . . . . .

Visual Representation of One-to-One

Figfire 6. Summary of SERVER TELNET commands . . . . .

s e e

E

W W oo 0 O W W W

10

II.

MOTIVATICN

Numerous requests have been received in the last six months to
improve the human interface to the UCSB On-Line System (OLS)
for network users. The problem stems from having to enter as
many as six keys to describe a single.OLS key. For example,
;PRED[SP] must be entered to specify the key (See RFC
216, Telnet Access to UCSB's On-Line System). One solution

to the problem has been to obtain and to use the custom OLS
keyboard.. However, this implies a capital outlay which is

not always justifiable for users with tight budgets. Thus the
following solution is offered as a compromise between the ex-

penée of a hardware keyboard and the awkwardness of spelled

out key mappings.

OVERVIEW .

The OLS keyboard, pictured_in Figure 1, contains 168 meaningful
keys. ASCII, the network standard for keyboards; allows only
128. Thus the mapp%ng described in this report relies on one-
to-one mappings for the most common keys and two-to-one mappings
using for less commonly used keys. Key assignments in ‘
the former case are picked so that location is approximately

the same as pictured in Figure 1. Key aSsignments in the latter
casé are picked, whgrever possible, to be suggestive of function.
In addition, options exist to reenable upper and lower case

alphabetics and to ignore line feeds after carriage returns.

pitoqiey $10 °T eandtg : . .

s3drxosxadng

NYALIY | 3SVD govds
. | : ’ ! W N g A ol X z
asveg o oove " < > nN | ovid |vias aN | o | oIx |viaz
w10 | 1as| ¢ ) ¢ 1 X r H o d a s | v
1+ J [ ] ¢ [TORYT|vadyd | VWOIS |VIIHL| VNNVO| Id | VL13a|VWOIS|VHdTY
vl = M R d 0 1 n A 1 b 1 M [0
1d % $ b Id |'DIWO| VIOI|'ISdn| Isd | nvl | OHY¥ |-1Sda3|voawo| IHd
' / - * 0 6 8 L 9 S ¥ g z 1
# ? - i 0 6 | 8 | ¢ 9 s | v g z R
LISTL | g : AVIdSIO .
3dvos3 _ :

43LNT 3Y0LS | AV01 ar ANOD | 13Q oYY | NVLV UMd | dX3 901 S02 NIS

ld3¥ | NOD N3 XL REQ aonW XVW gns TVAZ | NMOQ dan 143y Sy S1

-1S3L| @3ud| 1u0S| Qoud| WNS | 4410 ANI | £NOD | Luds | Ds @ ORN=] %:)

1SI7 | 2dAl | ¥asn LSAS{X1dWd| 1vayu| 114 IA A Al III II I 3

\

{
QivogAgEY $.0 LNIWAND

III.

Iv.

These options (seeFigure 6) are selectable via SERVER TELNET

commands following the conventions of RFC 216.

EFFECTS ON THE PREVIOUS SPECIFICATION

The one-to-one and two-to-one mappings described herein fall
completely within the previous specification of UCSB's teletype-
compatible interface. At any time the user may specify an
operator using the old style prefix and spelling. The old
SERVER TELNET commands still apply. It is suggested, however,
that the user change his prefix to be other than ;Aso that ; may

be sent as a single key.

All UCSB sockets which allow TELNET input may uée this new
mapping. The socket which supports graphics display on TEKTRONIX
series 4000 terminals and one socket which issues NGP0 output

are two such cases. (See RFC 398 fior a listing of UCSB's graphic

sockets.)

Control characters, which were ignored in the previous specifi-
cation, now map always into operators. Figures 3 and 4 show

this mapping.

DETAILS

A. Details of One-to-One Mapping

One-to-one mappings exist for A-2Z, 0-9, most punctuation, ERASE, and
most upper keyboard operators. The mapping for operators is

accomplished with upper case alphabetics and control characters

. MODE TO PUSH OLS OLS EXPLANATION SEND ASCII
BOTH MODES| 0-9 Numerics 0-9

[SPACE] [RETURN] Punctuation

BACK BACK] [TAB]

s<.>25 <225

(01&*s (la*s

=5+1- s%+l-

I:_':_ Ia'\”(_

LINEFEED DOWN (¥)

ERASE Erase Screen DEL

USER] - * Operators ta-tz
OPERATOR A-Z UC Alphabetics a-z

[LS]- [SIN]* Operators CA-Z
ALPHABET A-Z UC Alphabetics A-Z

a-z*% LC Alphabetics a-z

Figure 2. One-to-One Mappings

* See Figures 3 and 4.

**3-2z is actually Alpha-Zeta for local users.

users will see and use these keys as a-z.

However, network

' ~ LOWER UPPER
ASCII SHIFT SHIFT - CONTROL -
a A LS USER
b B ATAN DISPLAY
c c LOG RESET
d D REFL LIST
e E . II
£ F uP ENTER
g G DOWN REPT
h H EVAL BACK
i 1 INV (TAB)*
3 J SUB (¥) *
k K MAX LOAD
1 L MOD STORE
n M DEL (CR) * °
n N ARG ip
o 0 DIFF CMPLX
p p SUM SYST
q Q % g
T R 111
s s RS TYPE
t T sQ v
u u CONJ REAL
~ v v _ EXP CTX
‘w W I
- x X cos . PHR
y Y SQRT v
z z

SIN . NEG

Figure 3. One-to-One Operator Mode Mappings, Expanded

* [TAB] ,, and ICR! are not really operator keys, but are included
to be compatible with ASCII.

JNTROL — 3 T 1T TIT IV v REAL [ TAE | CMPLX | SYST
“PER — | @ ® ® ) - SQ | SQRT CONJ | INV | DIFF SUM
WER — Q W E R T Y U I ) P
CONTROL —> T "USER T TYPE | LIST |ENTER | REPT [(BACK) | (%) LOAD |STORE
UPPER — LS RS REFL | uP DOWN | EVAL | SUB MAX MOD
LOWER —— A S D E G H J K L

CONTROL — | NEG PWR |RESET CTX |DISPL | 1ID (CR)

UPPER — | SIN cos | Loc EXP |[ATAN | ARG DEL

LOWER —— Z X C v B N M

~ “Figure 4. Visual Representation of One-to-One Operator Mappings

in the OPERATOR mode. ALPHABET mode sacrifices the upper case
portion of this mapping, but don't panic. may be used to
return to OPERATOR mode for a single key (see details of Two-to-
One Mapping). FPFigures 2, 3, and 4 contain the details of the
one-to-one mapping. The ASCII keys FS, GS, RS, US, °, \ PR S T
are currently unassigned and may be used as convenient command

prefixes.

B. Details of Two-to-One Mapping

Two-to-one mappingé exist 'for the remainder‘of the OLS keys. 1In
all cases the first key of the two key sequence is . Either
of two actions may be performed by depending upon the
successor key. If the successor is not an alphabetic the
appropriate OLS key will be selected independent of mode, as
ocutlined in Figure 5. For example, [ESC|? will always give the
[TEST] key. 1If the successor is an alphabetic then it is inter-
preted as though the opposite mode were in effect (i.e. GENERATOR
is the opposite of ALPHABET). This may seem confusing, but some
useful effects are generated and will be illustrated by the ‘
following two examples. »

1. If while in OPERATOR mode the keys [ESCla are entered

the interpretation will be "a" (as in ALPHABET mode)

rather than "A". Thus users may enter lower case

alphabetics while in OPERATOR mode.

2. If while in ALPHABET mode the keys [ESC]A are entered,
the interpretation will be (as in OPERATOR mode)

rather than "A". Thus users may enter the operators

[TS] - [SIN]while in ALPHABET mode. The entire mapping

is outlined in Figure 5.

* %

\

MODE TO PUSH OLS OLS EXPLANATION SEND ASCII
BOTH MODES Shift 0 Shift Numerics [Esc]o-[ESC]9
-Shift 9
¢ Cent Sign [ESC]$
+ Line Feed Up
TEST Operators ?
PRED #
SORT %
conv [(Esch
CASE [ESC] (
ENL, CON . [ESC] >, [ESC]<
VI,VII &, !
PT [EsC] -
SET,CLR [Esc]+, [ESC] -
OPERATOR A-Z* [ UC Alphabetics A- Z
a-z LC Alphabetics [ESC]a-[ESC]z
ALPHABET A-2* UC Alphabetics [ESC]a- z
- Operators A- z
Figure 5. Two-to-One Mappings

*These cases are degenerate and minimally useful, but are
A-Z is best sent by a-z in
OPERATOR Mode and A-Z in ALPHABET Mode.

included for completeness.

**Note:

in actual usage these keys might be best handled by

spelling them out rather than looking at a chart.

New or Revised SERVER TELNET Options#*

A. OPERATOR/ALPHABET Option

A new option set by the OPERATOR command enables the one-to-one

mapping described above. The ALPHABET command restores the

.interpretation of lower/upper case alphabetics to that of RFC #216.

Users of the OPERATOR mode will seldom returfl to ALPHABET mode.
When ALPHABET mode is invoked, however, it will probably be to
use message generation on the TYPE level or upper/lower case

file creation using COL.

B. SHIFT/UNSHIFT Option

Another option, set by the SHIFT command, reverses the interpre-
tation of upper/lower case ASCII alphabetics. For example, if
SHIFT is invoked while in ALPHABET mode, a lower case "a" would
receive an upper case "A" ipterpretation (i.e. send an OLS "a").
Or while in OPERATOR and SHIFT modes a lower case "a" would
receive the upper case "A" interpretation, LS. The SHIFT option
was useful in the p{eviogs specification to gain convenient
access to upper case. For this new specification, however, its
usefulness is minimal, but might be used for a user who would
rather map upper case ASCII to upper case OLS and lower case

ASCII to operators.

~ *See Figure 6 for a summary of all available commands.

VI.

C. INTERPRETLF/IGNORELF Option
The options INTERPRETLF/IGNORELF exist due to the desire

to map directly into the OLS key [¥] (located over ).
Some terminals always send following . For these

‘terminals IGNORELF ignores the trailing ]L [, thus avoiding

spurious sends of to OLS. Most terminals, however, allow

the separation of and . For these, INTERPRETLF can be used to

cause all keys to be interpreted as.

CONCLUSIONS AND SUGGESTIONS FOR EASY USAGE

For these mappings to be most usef_ul, the user should have tape-
on labels for the fronts of keys A-Z and tA-tZ (the same keys
for most kej,'boards) . ' A reference card summarizing
double keypushes and special modes completes the necessary
equipment. The Computer Systems Lab will work with individuals

to create customized label sets.

It is hoped that the current experimental mapping will provide
more convenient input to the UCSB OLS. As network graphics
protocols become better defined, UCSB hopes also to enable more
output features not now available to network users. Any
criticisms, comments, or suggestions with this and future
improvements should be sent via network mail (e.g. SNDMSG) to

GRIPE at UCSB-MOD75.

10

COMMAND MEANING

*HELP Lists all NETOLS commands.

PREFIX (default=;) Change NETOLS command prefix.

SHIFT Lower and upper case ASCII is inter-
preted as upper and lower case ASCII,
respectively.

UNSHIFT (default) Lower and upper case ASCII is inter-
preted as lower and upper case ASCII,
respectively.

*FULLDUPLEX _ Causes NETOLS to echo all characters.
*HALF DUPLEX (default)  Disables NETOLS character echoing.
*STATE Displays status of all options.

- LOGOUT Sign off and break connection.
IGNORELF Ignore any m following n
INTERPRETLF (default) Interpret E following m as in

Figure 2.

OPERATOR ° __ Lower case and upper case ASCII are
interpreted as upper case alphabetlcs
and operators respectively.

ALPHABET (default) Lower case and upper case ASCII are
interpreted as lower case (greek) and
upper case alphabetics, respectively.

Figure 6.. Summary of SgRVER TELNET commands

*These commands are ignored on all sockets which output graphics.

AI ELI5

On this page
PROBLEMThe UCSB On-Line System had 168 specialized keyboard keys, but the network terminal standard (NVT ASCII) supports only 128 characters, forcing users to enter long escape sequences to access OLS keys.
MECHANISMRFC 570 defines a mapping using one-to-one assignments for common keys (A-Z, 0-9, punctuation, operators) and two-character escape sequences for less common ones. Modes (OPERATOR, ALPHABET) and options (SHIFT, INTERPRETLF) allow switching between interpretations.
STATUSNetwork users of UCSB OLS gained a more practical interface with single-key entry for frequent operations, reducing the need for custom keyboards while keeping backward compatibility.

§1Bridging a Keyboard Gap

The UCSB On-Line System (OLS) is a specialized system with a 168-key custom keyboard containing mathematical operators, function keys, and control functions not present on standard ASCII keyboards. The network terminal standard, NVT ASCII, supports only 128 characters. Previously, network users accessing OLS had to enter escape sequences like ;PRED[SP] (six characters) to specify a single OLS key. This made remote use cumbersome and slow, and many users wanted a custom OLS keyboard for their local machine, which was expensive. RFC 570 proposes a middle ground: a practical character mapping that gives network users faster access to OLS functionality without requiring specialized hardware.

OLS has lots of special keys that network keyboards do not have. To use them over the network, you had to type six characters for one key. This mapping makes it take one or two characters instead.

§2One-to-One and Two-to-One Mappings

The mapping uses one-to-one assignment for the most common 80 or so OLS keys: alphanumerics (A-Z, 0-9), space, return, tab, punctuation, erase, and many operator keys. In USER (OPERATOR) mode, uppercase letters map to OLS operators, and lowercase ASCII triggers two-character sequences. In ALPHABET mode, lowercase and uppercase ASCII map directly to OLS alphabetics.

Two-to-one mapping uses the ESC character as a prefix: [ESC] followed by a character selects less common keys (shifted numerics, special operators like PRED, SORT, CONV, TEST). For example, [ESC]? selects the TEST key. If the character after ESC is alphabetic, it is interpreted in the opposite mode (e.g., [ESC]a in OPERATOR mode gives lowercase 'a', allowing users to type both operators and lowercase letters in OPERATOR mode).

Regular letters and numbers map directly. Special keys use ESC plus another key. Modes switch how letters are interpreted so you can type both operators and regular text without changing mode much.

§3Modes and Options

The RFC defines several options. OPERATOR/ALPHABET switches the mode for letter interpretation. SHIFT/UNSHIFT reverses uppercase and lowercase interpretation. INTERPRETLF/IGNORELF controls whether a line feed after a carriage return is treated as a separate DOWN arrow key (common with some terminals) or ignored (since regular terminals send CR-LF as a pair for carriage return). The RFC recommends using key labels on standard keyboards to help users remember the mapping and a reference card for two-key sequences. All of these options are selectable via SERVER TELNET commands, following previous UCSB telnet specifications.

You can switch between modes: OPERATOR mode for functions, ALPHABET mode for text. You can reverse uppercase and lowercase if your keyboard sends them oddly. You can ignore extra line feeds that some terminals send.

§4References