RFC 418 UNKNOWN FILE TRANSFER · HOSTS

Server File Transfer Under TSS/360 At NASA-Ames Research Center

How NASA Ames implemented an ARPANET file transfer server on IBM TSS/360, with comments on the protocol.

On rfc-editor.org ↗
PUBLISHED
November 1972
AUTHORS
W. Hathaway
STREAM
Legacy
MAX COMMAND LENGTH
256 characters
MAX RECORD LENGTH ON RECEIVE
1012 bytes
DATASET NAME PART LENGTH
up to eight characters
DOI
10.17487/RFC0418

RFC text

Original text · RFC Editor View on rfc-editor.org ↗

This text was converted from the RFC Editor's PDF edition and may contain conversion errors; the layout is approximate. The PDF is the reference copy.

'­

                                                                                                           1 2.762

     NETI-lOHK WORK I JG GROU?                                       Hayne Hathaway ( flJ.1ES- 6 7)
     Requ est for Commen t s        ~418                             Novembe r 27 , 197 2
     Nr c if1 276 2
     Ca t e gor i e s D. 7 , G. 3




                            Se r ve r Fi le Tr ansfer Und er TSS/3 60
                                 At NASA-Ame s r esear c h Cen t e r




     r ni s RFC i s a des cr iption o f the i ni t i a l ~mp l eme n t a t i 0 n o f Se r v e r Fi le
     Tr a nsf e r. at N,\ S -I.-Ames r e s e ar ch Cent r , I t a l s o c o n t a ins s ome c cmme n t s
     on t he c u r r e n ~ Fil e Tran s f e r Pro t oco l ( RFC' s 354 -od 385) and some
     s ugge s ti on s f or fut ur.e ex ens i on s . Comme n t s or que s ti on s s ho u ld be
     d i r ect e d t o :


                                           '.Jay ne Ila r haway
                                           Na il St op 233-9
                                           iTASA- ne s Rese a r ch Cent e r
                                           Ho f f e tt Fie l d , C l~ 9l~ 0 3 5
                                            (415 ) 965 - 6033 or
                                            (408 ) 736- 7439

                                                                                RFC 418 Pa ge 2




TI1e k1PA Networ k =ilc t ransf er f acilities p r o v i d e d a t Ames i n t e r f a c e
v e r y cl o s e ly with the st and a rd TSS fi l e mana g ement f a cility; n etwork
u s e r s s h o u l d b e f ara i I ia r wit h TSS in g e n e r a l a nd its f i Le handling
c a p a b i l i t i e s i n part ic u la r . A few o f the ba si c conc epts are me n tione d
h e r e.      Ea ch per son a llowe d t o use TSS i s as si g n ed a use r id en t if icat i o n
( USERI D) , wh i c h i s padded to eight cha r a c te rs ui th a ste r i s k s by the
s y s t eru, At Ame s , t h e u s e r i d is normally f o rme d from a three l.e t t er
o r g a n i z a t i o n cod e a nd the us e r I s Ln i t i a l s , Ea c h us e r i d has its own
catalog ( d i r e ctory ) , wh i c h co n t s ins poi n te r s to a ll da t a s e t s (files)
wh i c h may be acc e s s e d by t he u s e r .          TSS da ta set n ames a re ma de up of
one or more cual i f ic a t ion l e v el s, up to e igh t ch ar a ct er.s each, sep ar ated
by pe r io d s . 1 h c highes t qu a l i f ic a t io n l c ve~ is in fac t the u s er i d , but
t his i s no t En tered whe n s p ec i f y i n g da t as e '; n ame s ; t h e c ur r e n t l y a c t i v e
uBerid i s a pp e nded by t h e s ystem to al l n m: es entered hy the user .
The Leve ln o f. qua l ifi cat i on form a t r e e s t r u c t u r e wh ich may be us ed t o
i d e n t i f y lo g ical gr o u ps of da t a s ets . Only ends o f br -nches a ctually
n am d a t asc t s ; suc h n aine s are t e rrne d " f u l l y qualified " n ames .            Pa r ti al ­
ly qu a li f i e d narne s a re u s e d i n many TSS d a ca s e t management c omma n d s
but a r e no t u s e d in AI{ PA Ne two r k Fi l e Tr ansfer . Host d atase t s u n d e r
TSS are co n t a Lne d o n a pool of un ivers a ll y a vailable disks tenne d
" p ub l i c s to r,ge . " Da t s e t s o n p u blic s to rdgc ar e au t omatica lly c a t a ­
l o g e d at c r e . .,t i o n . Da t a s e t s ma y al so e x is t on pr iva t e d e vi ce s , eit her
d i s k s o r t a pes .        Pri v a t dat as et s may be c 3t a lo g e d or n o t , a s the u ser
d e s Lr-e s , On I y disk datas e t s i n the " v i rt u a l a c c e s s me t h od " ( VAH) are
s up po r t e d by TSS Serv er Fil e Tr a n sfer , but private ViI:'1 datas ets may be
use d .: f c a t a l o g e d . Ampl e TSS commands ex i s t for tra n s ferri n g VJJ:1 d a t a ­
s et s t o t a pe , c a r d s, pri nter , etc .

The TS S c a t a l o g struc ture a lso a Ll ows ex t e n s i v e sh ar ing of d a t a s e c s
amon g u s ers.       Th i.s 'har in g n:ay he done a t        ny q:.la li fic a tion le ve l   nd
wL th read -onl y , r e ad-wr i t e , o r u al i mi ted ac c e s s ( o n l y unl imited sh aring
a llows e r as I ng ) ,     To share a TSS da .a s e t , r.he owne r must firs t " pe rm i t "
it t o on e or mor e u s e r s , Each u s er must the n e x pl i c i t l y " s h a r e " i t,
wh i ch c a u s e s a n e n t r y for t h e d atase t t o be made i n hi s c at a l o g . This
e n try , which ma y he u nd er a dif f erent n ame t h an the o ri ginal, do e s
n o t poi n t t o the d a t a s et it s e l f , b u t rathe . ~ p o i n t s to t h e appropr i ate
e ntry i n th e own e r IS c a t a l o g , T i s a l l ows t ' e own e r t o c h a n g e o r re ­
move s h a r i n g acc ess a t any im e .

TS S FI LE STRGCTURE

1\ b r i e f discus s ion is al s o i n r d e r ab o u t the d iffere nc e be twe c n un ­
st r u c t u r e d f iles a nd re c o r d - s truc t u re d f il e s . All f i l e s on TSS are
sto r e d 'Io1 i t h some f o rm o f re cord s rue t ure , a I tho u gh each r ecord may be
u p t o one mi l lion bytes i n l e n g t h; the i mp o r t a n t thing i s the mean i ng
a t tribut ed to a record .

For har a c t e r o rie nt ed d a t a s e t s (e. g . , s ou rc e pro gr ams , l i s ti n gs, pr ogr am
d o cum en t a t i on ) a r ec o r d c orr e s p o nd s to a 1 i n c ; t h e r c ar e no end -of ­
r eco r d mark e rs in the da t a it s el f (C R-L?, NL, r:OL) .                 Th e TSS e d i t o r s
require t his , t h e t r r.ns l a t o r s re q uir e thi s and so for t h.            Thi s do es not
p r e c l ud e h av i .ng a n EBCDIC "new- Li n c " cl a rac te r ( NL) in h e c a t a , how­

                                                                        RFC 4 18 Pa ge 3


ever ; it is ju st trea t e d as par t o f the l i n e of dat a . . hus ch a r ac t e r
oriented fi les must be sent to and sto r ed on TSS ,. . ith r e cord s t r uc ­
turing t o c us e f u l :

The u s e o f uns t r uc t ur ed f i l e s on TSS i s us ually rest r i cted t o bin a r y
data and ob j e c t pro gr ams . From t he net'. . ork t h e onl y u s e fo r s uch f i l e s
wou ld be dat a whi c h i s in fa ct a t o t a l ly uns tr ucture d s t r i n g o f b i t s
( us i ng INAGE type). An examp le mi gh t be a n ob j e c t pr o gr am for an IHLAC.

Becau se o f the a bove , ou r s erve r h as imp lement ed t he fol lowi ng c on ­
ve ntions .

Sendin ~   structured dat a ( RETR, STRU R) :

      An end-o f -record      eq ue n ce wi l l b' add e d to e a c h r e c or d read fr om
       t he TSS da t a s t (e i t he r " s t r e am" mode CI - LF o r " t ex t " mode Ea R) .

Sendi ng un st r uc t ur ed dat a (RETR, STRU F):

      The da t a ~ i l l be sent wi t h no end- of - re c ord se qu e nc e a dde d .

Re c ei vi ng s tr uc tur e d d t a ( STa R or   PPE, STRU R) :

      An e d- o f-r e c or d s equ nce i s r e qu i r ed t o def i ne e ac h TSS re c or d
       (wi t h a meximum r ec or d len g t h o f 101 2 by t e s ).

Rec e i v i ng un s t r uctur ed data ( STOR or APP E, STRU F) :

      Every c hara c te r r eceived i s wr i tt en i.n t o a rb i trary s i z e d r e c or d s
      ( ex ce p t fer " text" mode EO F cha r ac t e r ) .

The above Ln p l e.. e n t a t i on does sa ti s fy one c r i t e r i on ( a s state d in t he
t h i r d sentenc e of I I I . C i RFC 35 4) : an y f i l e sent t o TS S may be r e ­
tri sv e d ex a ctly a s sen t . F r ex ample , t hi s me ans t hat i f a charac te r
f ile i s s ent in uns truc t ured form , the CR- LF s e quenc e s wi l l be s t or e d
as p&rt of t he data. \~ l en this dat a s e t i s r c t r i ev ed (a l s o in unstr uc ­
t ur ed fo rm) no new e nd - of - re c or d i nd i c a t or s vri .Ll, be adde d, s o t he re­
t r i eve d fi le wil l have onl y the or igina l CR- LF rec or d i n fo rma t i on .
If the file wer e re t r i eved in reco r d-struc tu r c:.d form , howev e r , th i s
woul d of cour s e no t be t he c a s e ; i t i s impo rt an t that any unstr uc t ure d
f ile be r e t ri eve d i n exactly t he s ame manne r t ha t i t was s en t .

This c r i t e r i on o f retr ievabili ty is no t t he ma i n one o f conc ern t o
TSS us e r B, ho\ ever ; a a re i mpor tan t c ri t eri on is t ha t f i l e s sen t t o
TSS may be of us e on that s ystem ( L e . , may be edi t ed, may be pr in ted ,
e tc . ) . To a ccomplish 'hi s i t i s imperat ive tha t cha r a c t e r data be
sen t wi t h record st ructu r e .

As can be seen f r om the a bove d i scus s ion , th i s should not b . a prob l em
\.;i th rno s t ha s t s , as in d f a ul t t r , ns f e r s (MODE S, TYPE A) t hey are a l ­
ready i n lud i n g e nd-o f- r e c ord info rma i on a t t he e nd o f e a ch ph ysi c a l
1 i.n e ( CR- LF) . Thu s the on l y r e qu i r mont wou l d be t o no t r e j e c t t he
STRU R c omma nd ( a t le a s t in NODE S, TYP E A t r an s f e r s) . Thi s may c a us e

                                                                            RFC 4 18 Pa ge 4


s ome minor pr ob l ems ( s uch · s CR- L -L F- LF- LF f or ve r t i ca l s pa ci n g) but
it i s strong ly re uested that host s whi c h do not us ua lly st ore f il e s
in re c ord - st ructure form at l e as t i mpl eme nt STRU R i n th i s s imp le
c on t ex t.

TSS SERVER FILE TRA..~SF E !( nlPLENENTATIOj:~

The TSS i mpl emen t a tion of each o f t he fi l e t r a ns f e r comma nd s is de s ­
c r i be d be l ow. The maximum length for a c omman d and its paramete r s i s
256 cha r a c t e r s ( no t including t he CR- LF a t t he end ) . All blanks a r e
r emove d from t he parame er st r ing , aId s o b l an "s are ne ver si gni f i cant
e xc e p t t o sep~rate a com~and f rom its pa r ~~e ters.

Onl y he c ommands HAIL and MLFL may be u s ed when the re i s no ac ti ve
u s e r l ogged 0 1. ; al l o t he r co.mnands r e qui r e n pri or USER command .



The USER c ommand de f i ne s t he TSS lls e r i d t o be employe d f or c a t a l og a c ­
c e s s . Thi s must be a va l i d TSS use r id , but it mus t a l s o h av e be e n
s pe c i f i ed as h avi ng a c cess t o ne t wor k fi l e t ransfe r . Th i s is do ne by
i ns t a ll a t i on manageme nt in a anne r s i mi l ar t o e stabli sh ing a v a l i d
TSS us e r i d ; con t a c t Wayne Hathaway t o have exi s t ing TSS user ids jo i ne d
t o ARPA Ne t wor k Fi le Transfe r. The demon st r at i on userids ARPA, ARPA1 ,
a nd ARPA2 do h.::?ve a c c e s s t o f i l e t r a n s f e r .

The USER c Olmna nd also r e s e t s a l l f i l e transfe r paramete r s t o t he i r
de f a u l t va lues , i nc l udi ng HOST a nd SOCK. It is f e l t t h i s s h ou l d have
b e e n spe cif ied in t he pr o to co l .

I f a USE R co . and is e nt e r e d dur i ng a f i le l: r a n s f e r op e r a ti on i t wi l l
be hc: l d unt i 1 the t r a n s f e r i s c om p le e ; he new us e r i d \"i 11 he n be
proc e s s e d , a p a s swo r d may be requested , etc .

P SS

TSS fi le t r an s r e r pas swords are o p t i on al a nd a r e e s t ab li s he d when use r i ds
are gran ed f i:e t r an s f e r acces s . This pa s s ~ord i s not ne cessar ily the
s ame as t he nOl1nal TSS passvord . The demons t r a t i on use r ids ARPA, ARPAl ,
a nd ARPA2 have no pa sswo r ds .

ACCT

The ACCT c omm ~~ d i s no t s u ppor t e d .

The pro to c ol seems somewh t defic ient i n the def init io n of t he ACC T
comman d , pa rti c u l a r l y i the assign i ng of r e p l y codes . I wou l d l ike
t o pr opos e tha t code 33 1 be ass igned t o " -::: N TI~ R ACeT" when t he ACCT
c omma nd i s requ i r ed for "log-on" and code 1~ 3 3 be a s s i gne.d t o " ENTER
ACCT" when the .ecl' c ommand is requ i ted on ly for a part i c ular t r a ns f e r
op e r a t ion . It is fel t that this would a i d us er automata i n s a t i s f y i ng
par t i c u l a r s e r ve r r e qui r emen t s .

                                                                                  RFC 4 1 8 Pag e 5


BYTE

Th e o n ly BYTE size        s ~ppo r te d   is ei ght .

SOCK

The SOCK c on:m a n d is supported i n ac c ord a nc e ' vi t h the p r o t oc o l . The re
i s o n l y one HOST parame te r , how e ve r , wh i c h app l i es t o bo t h s e n d a n d
r e c e i v e s o c k ets.

TYPE

Ty p _ curren t ly suppo rted are . SCll an d ll'lAGE.                      Th e EBC DI C typ e "7i 11
be a d d e d l at e r . The two " p r i n t f il e " t y pe s a r e n o t y e t sup po r t e d , due
p a r tl y t o lack of t ime and part ly t o a seen ing fa u l t i n t he pr ot o c o l ­
i t appears t l.e only t r a n sf e r mo d e wh i ch a ll ows a " p r i n t fi l e " i s BLOCK.
Th is i s baser. on the d e s c r i p t i on s o f t r a ns :Ee r mod es on pa ge 12 o f RFC
3 51~ : TEXT mod          a Ll ows on ly ASCII t yp e, a n d STRE AH moue a l Lows r e c o r d
st r u c t u r e s (s u r e l y n ec e ss a r y i n p r in t f i les ) o nly in ASCI I type .         I
a s sum e t h i s j.s an over si gh t ; a nd '17(: i n f a c c i n t e n d t o s u pp o r t EBCDI C
typ e i n S TRELM mode Hi th r eco rd st r u c t ure s (si n c e EBCDI C c on t a i n s b o th­
C , and LF ) .         I f n o t , th e i mp l eme n t ati o n o f " p ri n t f il e " t yp e s .wi ll be
d e l a y e d s u b s tan t ia l l y .

STRU

Bot h f i l e a nd rec o r d s tr uc t u r es a r e s u p po r t e d , i n a c co rdanc e Hi th the
pr o t oco l .   Th e EBC DI C typ e ""i ll be s u p po r ted wit h re c o r d st r u c tur e ,
h owe v e r , a s i ndi c a t ed und er the TYPE c omman d .

r-10DE

The STREi\H a nd TEXT modes are c ur r e nt ly s uppo r t e d for t he i ndic at e d t y pe s
( STREAH is r e q u ired fo r HIAGE t yp e ) .            I n S':":'REAJ.'1 mod e "7ith reco r d s tru ­
t u r e s , the CE- LF s eq u e n c e (wi t h o p t i o n al Te l ne t; NOP ' s ) i s r e quir ed a s
EOR.       In TEX1 mode Hi t h no re c o r d s t r u ctu r e any EOR c h ar ac t er s e n c o u n ­
t e re d are dis c ar d e d .     I n TEXT mode wi th r ecord s t r uc t u re a message c o n­
t ai n i n g o nl y a n EOF c h a r ac t e r is as s umed t o be a n e nd-o f - f i l e o nly , n o t
a nu l l r e c o r d ' l7i th a n ami t t e d EOR ( a l t ho u g h we wo u Ld l ike to c on t i.n ue     /'
o u r l o bb yi ng aga ins t " i mp li e d EOR" c o n c e p t s ! ) .

RETR

The RETR c omma n d i s s u p po r t e d i n a c c o r danc e wi t h the pro t o c ol ; . the p a r a ­
me t e r mus t be a fu lly q u a li f i e d n ame o f an e xi s t i n g da ta s e t o n d i re c t
a c c e ss st o ra g e (pub l i c o r pri va t e ) . Fo r s t r u c t u r e d fil es i n ASCI I t y pe
a " CR·· LF" s eq ue nce i s inse r t e d a t th e e n d o f e ach re c o rd .         No EOR cha r ­
a c t er s a re i n s e r t e d f o r u n s t r u c t u r e d f il e s in TEXT mode .

STa R

The STOR c onau a n d is S lip o r t e d in a c c o r danc e wi t h th e p r o t o c o l ; t he pa ra ­
mo t c r mus r be a va lid f u l ly qual if ied d atase t n amc , Hit h u n l i mi t e d o r
r <' nd - wr i t . a c c e s s requ i r ed f o r e x i s t ing sh a re d d a t a s e t s . The c h a r a c ­
t e r i s l ic s o f t he TSS da ta set be ing sto r ed a r e de t er~mi ne d a s f ol l ows .

                                                                             RFC 418 Pa ge 6


For new da t a s e t s , the defau lt ha r a c t e r i s t i c s are VS or gani z a tio n wi t h
a m aximl~ r e cor d s i z e o f 1012 byte s . Thi s nay be ove rri d e n by s pe c i ­
f y i ng an ALLO ( TS " DDEF " ) c omman d ~., i th d i f f e r e n t c ha r a c t e r i s t i cs . A
'ISS " l i ne datas e t" may t hus be c r e a t e d by f i r s t e n t e r i ng an ALLO c om­
mand s pecifying VI organi z a t i on ( line n umbe r wi Ll be i n s e rt e d by t he
s y s t em). Fo r other types of 11 da t a s e t s , ho we ve r , t he us e r must e ns ur e
tha t t h e r e c ord s c on t a i n keys in t he sp ec i f ie d pos i t i on s a nd t ha t they
are sent i n orde r by key ; i t i s a n t i ci pa ted t hat t his f ac i l i ty wi l l
be r a r e l y u sed .

For e x is t i ng da t a s e t s , t he new v e r si on wi l l be c r e a t e d wi t h th e s ame
cha r a c t e r i s t i c s a s the ori g i na l ( an d on t he s ame pr i v a te vo l urae) .

APPE

The APPE command i s suppor t ed i n a c c or dance wi t h t he pr o t oc o l ; t he
parame t e r must be a va l i d f u ll y qu ali f ied « a t as e t name, wi th un limi t e d
or r e ad -wr L t e a c c e ss req u ire d f or ex i s t i ng s ha r e d dat a s ets. The c ha r ­
a cte r i s tic s o f c r e a t e d da t as e t s a r e dete r mi.ne d a s fo r th e STaR c omma nd.

RNFR

The RNFR command i s suppor t e d in a c c or'danc e wi t h t h e proto c o l ; t he pa r a ­
meter mus t s pe c i fy t he full y qua lifi ed name of a n e x i s t i ng da t a s e t .

RNTO

The RN TO c omm and i s sup po r ted i n ac c o rd a. i c e wi.t h t he protoc ol ; th e p a r a ­
me t e r must s pe c i f y t he f u l l y qualif i ed name of a none x i s t en t da t a s e t.

DELE

Due t o t he 'ISS fi l e s ha r ing and pri va t e de v i c e fac il i ti e s, the si n g l e
DELE command i s no t re al l y ade quat e . I n 'ISS the r e a re t wo s parate
commands f or t h i s fu nction , ERASE and DELETE. The ERASE c omma nd i s
used t o ac t ua l ly pu r ge a datas et and f r e e it s s pac e ; i t 1 ay be us e d
on l y on dire c t a c cess data s e ts ( publ i c or pr i va te ) wi t h un limi t ed ac c e s s .
The DELETE command s i mply r emov s a c a t a l c g en t r y a nd doe s not t ouch
t he da t a s et i t s e l f ; i t may be us e d on s ha r e d d a t ~s e t s of any type ( t o
e f f e c t i v e l y " un s ha r e " ) o r on da t a se ts on pr i v a te de v ices . To a t t empt
to provide bo t h of t h e s e f un c t i ons , th e DELE c ommand ha s be e n i mp l e ­
me n ted a s fo llows .

Fo r non share d     a tas ct s :

       Pub l i c o r pr i vate d ire ct- ac c ess :
               e ras e ( f r e e t he spa ce ) and de l et e t he c atal og en t r y

       Pr iva t e nond i r e c t- a c c e s s:
              de l et the c a t a l o g entry only

For s hared da t a s e t s :

       ~Ib li c  or priva t e d i r e c t - ~ c c es s , un l i mit e d s ha r i ng :
              e ras e ( f r e e the spac e ) a nd de le te the c a t a l og e n t r y .

                                                                             RFC 418 Pa ge 7


       .1 1 others :
             delete t he sharer 's c a t al o g en try on l y

ALLO

The ALLO c orrman d is se d t o enter a TSS " DDEF 1 1 c orrma n d . Thi s may be
used to sp ci f y non st a ndard d at aset a ttr ibute s , pri vat e de i c es, or
o t he r i t ems . The par ame ter is a omplet TSS " DDEF" c orrunand mi nus t he
wo r d "DDEF" itse lf, wi t h t he mi no r re str ict ion t ha t t he f irs t t hre e
p a r ame t e r s (DD.TANE, DSORG, and DSNANE ) mus t be pr e se n t and mus t no t
be s pecifi ed i n ke )~ord fo rmat .

REST

The REST . comma nd i s not s upported.              It Hill be add e d when BLOC ' mode
i s i mp l eme n t e d .

STAT

There are th ree u s e s o f th e STAT c omma nd .            If used betwe e n f i l e t r a ns f er s
wi t h no prrr ame re r , i t pill pr i nt t he c ur r e nt val ue s f o r a l l f i l e t r an s ­
f e r pa r ame t e r s ( u s e r , by te s i ze , h o s t, r e ce i ve data s o c k e t , s e nd d a t a
socke t, tran sfer type, fi le s r uc t ure , a nd t r a n s f e r mode ) . If us e d du r ­
ing a fi l e t ran sfe r op e ra t i on ( wi t h or wi t hou t a pa r ame t e r ) i t wi l I i nd i ­
c a t e wha t type o f ope r a t i on i s ac tive .

The t h i r d US2 o f STAT is t o ret r i .v s ta t us i. nf on na t i on abou t a f i le or
gr oup o f fil e s (i . e ., any quali f ica t i on Le v e L } , The r e a re t wo fo rms f or
 this f nf o rma t Lon , t e rmed shor t nd l ong . Th e short f orm w i Ll, ind ic a t e
wh t dat as e ts e" i s t wi h the qualificat ion l e v e l s pe c ifi e d , Hith i n f or ­
lna t i on about s 1 a r ing and p ri vate devi ces . I f the p a r ~ne t e r spe c if ierl
 is a f u l l y qual i f i.e d n ame , the e tire da ta se t name i s pr inted . If i t
 i s p a r t i a l Ly q ua Lt f i e d , t he names o f al l d a t as e t s in t ha t gr oup ar e
print ed (Hi t h o n l y t l e m i que por t i on o f the names act ua l l y ap peari ng ) .
 This . hart f orn i s exactly eq ui valent t o the TSS "PC?" c omma nd and i s
 t h e deraul. fOlm fo r STAT.

The p a r ame t e r f or t h e:: l ong form ' s t h e s ame as f or t h e shor t fo rm , bu t
all avail ~ ble i n f orma t i on is pr inted f o r e a c h data se t (a t leas t f i ve
l ines p e r data set). '1'0 get the lon g form , t he charac ter s " , LONG" mus t
be app e ld ed to t he pa r a~eter . The lon g fo rm i s exac t l y eqUivalen t t o
t he TSS " DSS?" c omma nd .

Tt,e TAT c ommand does not c ur rentl send a rep l y code 200 at al l . I t
is elt t his sholld be a dde d to the pr otoc ol t o be t ter d efine the e n d
o f STAT informa t ion ; the r e pl y code 200 wil l be a dd e d at t h a t t ime .

LIST

The LIST c omma nd produc e s ou tpu t i de nt ic a l to the s ho r t and long fo rm
ST,\T c ommand ( pa r ame t c r e qu i r ed ) e xc e p t t h a t th e lo ng form is t he de­
fault ; to ge t t he short f orm , the chnr a c t er s " , HORT" must be a ppe nded
to th e p~r am ete r .

                                                                             RFC 418 Page 8


ABOR

 Th e ABOR c ommand may be en te red a t any time dur ing a f i. Le tr ansfer o pe r­
 ation . I t vri Ll c au s e an i mme di at e t c rmi na t i on o r the t r a n s f r and c l o s ­
 in g of th e d~ ta c o n n e c t i o n.   Fo r RETR o perat io n s , the TSS d~ t as e t will
b e un affect e d.       Fo r STOR or APPE 0 a new da t a s e t , ther e will b e no th ing
 c re a t ed ( e xc e p t poss ib ly n Ln t c rme d i. t e f ile wh i ch should be i g no r e d ) .
 For STOR of 81 exist ing d ataset , the datase t wi l l be u n c h a n ge d. For
 APPE t o an ex i s t Lu g d a t a s c t , a l l tr a n sferred i n f o rm a t io n vi. Ll have been
 wr i . t e n in t o the d a ta s e t.

BYE

Th e BYE c ommar d i s su p po r cd in ac co r dance ~'li h the pro t o c o l.      I f a ·BYE
c omm a n d is entered du r i n g a t ran sf e r operat i on · t he nex t comma n d en te rcd
(wh i c h mu s t b e a USER cornman d ) wi Ll n ot b e p r oce s s cd a t all u n il t h e
t ran sfer is c( .mplet e . Note t h e t th is p r ec l udes a bo r t i n g the t r a n s f er
after a BYE c o~mand i s e n t ered (wh i ch s e ems t o f i t the s p iri t of BYE ) .

HAIL

The l lAI L c onm a n d ,.,ill acc e pt a TSS us e r Ld , a known NI C i d e n t (L e . , o n e
f o r \..hi ch a m.rpp i n g 0 TSS u ser i d exists ) , o r ~ nu ll p ar-ame rc r ( i n
wh i.c h c ase t h c ma i l will be sen t to t h e TSS s y s tems pxo gr ammi.n g grou p ) .
Unl nO\·;'11 iden t s \.,i 11 c a u s e the NAI L corrnn n d t o b i gn ore d .

The 101 TL c omm. nd may be ente r e d pri o . to t h e f ir t USER c omma n d , to i n­
c r as e the i.c L Li, t y o f the ne two r k mai 1 syo em. Th is i s no t c u rre n t l y
mentio ned in t he protocol; it i s f elt tha t t hi s imp lementation s h o ul d
be r ee omrnendc I .

HLFL

The p a r amet er L s t he same as for t he HAI L c omma n d ,

The NLFL c ornm s.n d may als o be enter d pr io r t o a US ER command , f o r t he
s ame re asons i n d icat e d und er ~L~IL.

c m r-1EN'IS ON 'IE..:. PRO TOCOL

Some po s sib le a dd i t ions t o th e Fi l e Tr a n s f er Comma n d Set         re as f o l l ows ,

NOP

I t s e e ms stra n ge t o f ind any pr ot oco l ' '''i tho u t a no - ope rat i on c omman d ,
a n d th e re ar e severa l possibl e us e s for s uc h a command . As s tnning
t h e r e is a s p e c i a l reply c od e as s i gn e d to " NOP C O~'l l'W; ACC EPTED, "
t h e n NOP could se r ve .he s ~ne fun ct ion as th e l e vel 2 EC O (fo r user
v e r i f i c a t i o n of s erve r e x is te n ce , fo r e xam p l e ) . Anothe r ex amp le co u ld
b e in a ll owing he us e r t o d iscard term i n a l o u t p u t , as f r om a to o­
l e n gh t y STAT c ornman d , Th e problem "' ith j us t disc ardin g ever ythin g is
th a t th e lIs e r process do e s n ot k n m'" ""he n a l l o u :pu t has be en r eceive d .
If a NOP comma 1u we re c1 -f i ne d , t h e tls er proc ess c o u ld s e nd a NOP upo n
r ec ei pt of t h e dis ca r d r e qu e~t , and t hen di s ca rd un t il t he unique NO P
  espo n s e i s rec e i v ed .

                                                                               RFC 418 Pa ge 9




SRVR                                                                                                        r

The S VR CO l. , a nd wou Ld be used t o pa s s a parame t e r whi ch ha s ' s i gn i f i ­
c a nc e only t o the part i cular s erve r s y s t em. Th i s p ar ame t e r mi gh t
s pe cify printing a newl y c r e a t e d fi le , .ov i ng a fi Le , or any n umbe r of
s erver - de f i ned functions . One ossi bl e i mp lemen t a t ion wou l d be f o r t he
pa r ame t e r to be a v a li d s e r ver s yst em c omma nd , whi c h w u l d t hen be
It ob ey ed " by the s erv er .

To s implify i mpl emen t ation o f bo t h SRVR a nd STAT c omman ds , the f o L l ow­
i n g ch a nge t o th e proto c o l is req ue s t e d . Be t ween t he re ce i pt o f a
STAT or SRVR r.mrnna nd a nd t he s end ing o f a rn c ogn izabl e r e ply co de (i. e.,
any mess a ge H.Lt h n umbe r s i.n t he fi rs t t h r e e po si t i ons ) , a s erve r i s
a l l owed to send mess a ges wh i c h do no t h ave va l i d r e p ly c ode s . Thus t he
se r ve r 8Y t ern r e s pon s e mes s age s cou l d be sen t with no mod i f i c a t i on ( e x­
ce p t to Ln s ur e t h a t the f i rst tree po s i t i o s are no t nume r i c ) . The se
me s s age s wou l d be assume d t o h a ve co de 000 a nd s hou l d be pr i n te d by
a ny us e r pr oce s s e s . Thi s t.e c hn i qu e c ou l d po s s i b l y be e x t e nd e d t o o t he r
cOlum and s wi t h good r e s u l t s .

CLSE

Dur i ng i mp emcn t a t i on o f t he Fi l e Tra n s fer J erv e r th e f ol lowi ng ope r a t ­
i ng mode was c ons i d e r e d , t ha t of t he s o - ca l l ed It ho t c a r d r e a de r . 1t I n
t h i s mode a c onne c t i on wou l d be es t a bl i s hed between t H O s y s tems onc e
t o be l e f t ~ ~e n for an ex te nde d pe r i od . I nd i v i dua l us e s wou l d en te r
USER c omma nd s , t rans fer fi l es , and then en te r BYE c omma nd s t o s a f e ­
guard their f i Le.s , For t his mode t he BYE c ommand sho ul d no t c l o s e t he
TELNET c o n n ec ~ i o n . In fa c t , this i s he de f ini t i on of t he BYE co m­
man d i f ente r 2d dur i ng a tr ans f er and i f a ne w USER c omma nd c ome s be ­
f or e t he r an.s fe r is iom p l e t e .

To e H rn f. nat e : he t i mi ng un c e rta i n t i t i e s of t he BYE comma nd , and a l so
to a I Low th e "ho t c ar d reade r " mode , it is re commended tha t t he BYE
c omma nd be r e de fin e d to mean " t e rmi na t e t he c ur r e n tl y a c t i ve us e r and
req uire a ne w USER c omma nd be fo r e ad d i t i ona l. t r a n s fe rs . " The TELNET
c onne c t i on s c )u l d f cour s e be c l o s e d by t h ~ t s e r" pr o ce s s a s s oon a s
t he BYE command i s acknow l.e dg ed . For sc r pro c e s s e s t ha t c a nno t or                            \
do no t choo s e to do this, a new comma nd CLSE shou l d be a dde d , t o ha ve
t he me a ni ng o f "c l o s e the TEUiliT c onne c t ion when po s s i b le ( Le. , aft er                     \
a ny acti ve t r a ns f e r i s comp le t e ). "

Thus BYE wou l d h a ve on l y the mean i ng i t c ur r e n t l y do es if e n t e r ed d ur ing
? n a c t ive t r an s f er , and CLSE wou ld ha ve th e cur r e n t meani ng of BYE i n
o t he r c i r c ums t a n ce s . Further sugge s t i o .s wou Ld be t ha t CLSE i mp l i e s a
BYE and t ha - a e LSE d ur ing a n aC l.ive t r a ns f e r " l og i c a ll y " clo s e s the
conne c t i on i mmed i a t e l y (L e. , r:.o comma nd s may be c t e r e d wh i l e wa i t i n g
fo r the transf e t o c omple te ) .

Some small i t ems missing fr om t he p r o t o c o l a r e 11m·1 me n t i one d .

                                                                            RFC 41 8 Pa ge 10


DEFAULT PARANETER VALUES

I t shou l d be more empha t i c ally s t a t ed t hat serv e r s mus t a ss ume de f a ult
value f o r a ll unspe c i fi e d par ' e t er s (Ha DE, TYPE, e t c.). Hi tho u t th i s,
a ll us e r pr oc e s s e s mu st a l wa y s send 11 c mp l.e t e se t o f pa r ame ter spe c i ­
f i c a ti on c omma nd s, s i nc e sone s e rver s omeHhe r e ma y no t ma ke t he cor r ect
def a ul t a s sump t i ons . This is obv i ou sly unde s i r a b l e .

SY CH ON THE TElN ET           CONNECTI ON

The pr o t oc ol s t tes t ha t t he ABO. c om:na n d s hould be pr e ce de d by t he
Te lne t SYNCII cond i t i on , for reas ons o f e ff i c i e nc y ( so t ha t s e rve r s do
no t need t o be con tinua lly che cki ng t he Tel ne t co nnect i on during a t r a ns­
f e r) . Thi s should be ex t e n ded t o o t he r c onmands wh i ch may be u s e d dur­
i ng a t r ns f er ( BYE , USER, STAT, e t c . ) .

BREAK a   1   THE '.i.' El NET C Ol~rE C T ON

The qu es t io n o f vha t a BREfX c ha r a ct e r m e a ~ s ov er the Te l ne t co n nect ion
is no t to uched . Eve n i f t he BREAK i s t o h 2ve no fu nc t i on th i s shou l d
be s pe c i fi e d . I n the TSS i plemen t a t i on , t he onl y t i me a BREAK is re­
c o gn i ze d i s dur i ng a HAI L c ommand ; the BREAK will a bor t t he c omma nd and
c a nce 1 t he ma i l ,

CATCH- ALL REPLY CODES

It i s fe l t t ha t on e re p ly c ode of e a ch t ype should be a s s i gne d t he me a n­
i n g of "ot r." r " s o th a t s y s t em- de pend e n t c" en t s co ul d be pro pe r l y id e n­
ti fi ed. For e x amp l e , if a n i.nd e xed f i l e i s bein g s e n t to TSS a nd r e cor d u
a r e re ceived lIt o f or der , t he rep l y cod e c u r r en t ly use d i s 453 , al t hou gh
t h i s i.s s u ppo s e d to mean " i n s uf f i ci e n t s pac e . II If a c atch- a l l c o de we r c
de f i ned , t he me ss age t e x t coul d be us e d t o f u r t he r s e c i fy th e e x a c t
me an i ng .

PARAMETER VAL LDATI ON

Cer t - i n s e r ve r pr oc e s se s ( no t a b l y TENEX ) have a ppar en t l y d ivi ded t he fi l e
 t r a ns f e r c omma nd s i nto t HO lo gica l gr oups : pa r ame t e r s e tti ng c omma nd s
and fi le man i l' ulation c omma nd s . The pa r amete r se tt i ng c omma nd s are TYPE,
}10 DE, STRU, a nd BYTE . The parame e r va l ue s spe c if i e d on these c omma nd s                    \
a r e no t va l id a t ed Hhen re ce ive d ; th e y are s i mply st or e d an d a r ep ly c ode
200 i r e t u r ne d . The pa raI:leters are va li da t e d on t he ne x t f i l e ma n ipu ­             \
l a tion c ommand , hOHever , with e rr or s r e s u l ti ng in c a nc e l la t i on o f th e
f i l.e man ip u l a t ion c ommand i t s e If ,.;r i t h r e p l y c ode 50 3 .

I am aware o f th e pr ob l ems wi.t h va l i da t in g pa r am t.e r s whe n r e c eive d ( L e . ,
o f t empor a r i l y pr oduc i ng i nva li d c omb i nat i on s whe n ch a ng i ng f r om one val i d
s et to anothe r ) but i t i s felt th a t some s t a nda r d c ou l d be se t up t o a ll oH
t hi s . As an a hs o l u t e mi n imum, t o t a l l y i nv al i d or unsuppor t e d parame t e r
va l ue s s hou ld be d iagnose d Lntmcd i.a t e l y ( e . g . , Ha DE 13 if BLOCK mod e i s no t
i mp l eme nt e d) .

This prob lem i s a nu i s anc e wit l: a human us e r , but it be c ome s quit e s e r ious
wi t h a u s e r a u t oma t on: t he amoun t of wo rk ne c e ss a ry f or an a ut omat on t o
empir i ca lly de t e rmine a vali d se t o f parame t e r s i s in t o l e r ab le .

AI ELI5

On this page
PROBLEMThe ARPANET file transfer protocol had to be mapped onto the dataset and catalog conventions of IBM's TSS/360 system.
MECHANISMThe server maps TSS catalogs and record-structured datasets onto the transfer commands, using stream or record conventions for structured and unstructured data.
THE CATCHThe note also comments on the current protocol (RFC 354) and offers suggestions for future enhancements. The scan is poorly legible, so only its readable parts are summarized.

§1Purpose

RFC 418, dated November 27, 1972, describes the initial implementation of Server File Transfer at the NASA Ames Research Center. It also contains comments on the current file transfer protocol (RFC 354 and a companion RFC) and some suggestions for future enhancements.

The scanned text is only partly legible, so this summary covers just the parts that can be read. See RFC 354 for the protocol itself.

A report on how one big computer was taught to share files over the network.

§2TSS Files and Catalogs

Each user of TSS is assigned a user identification (USERID), normally formed from a three letter organization code and the user's initials. Each userid has its own catalog holding pointers to all datasets, whose names are made up of one or more parts of up to eight characters separated by periods.

Datasets can be shared among users by permitting and then explicitly sharing them. A shared entry points to the owner's catalog entry, so the owner can change or remove sharing at any time. Only disk datasets in the virtual access method (VAM) are supported by the server.

Every user has a personal list of files, and files can be shared by pointing to the owner's entry.

§3Structured and Unstructured Data

All TSS files have some record structure, and a record may be up to one million bytes long. The server sends structured data (STRU R) with an end-of-record sequence added to each record, and unstructured data (STRU F) with none added.

When receiving structured data, an end-of-record sequence is required to define each TSS record, with a maximum record length of 1012 bytes. Unstructured data is written into arbitrary sized records. The goal is that any file sent to TSS can be retrieved exactly as sent.

Some files are lines of text and some are just a stream of bits, so the server treats them differently when saving.

§4Server Commands

The maximum length of a command and its parameters is 256 characters. Blanks are removed, so they matter only to separate a command from its parameters. Only one command may be used with no active user logged on; all others require a prior USER command.

USER sets the TSS userid used for catalog access and resets transfer parameters to defaults. File transfer passwords are optional, and the demonstration userids ARPA, ARPA1 and ARPA2 have none. The ACCT command is not supported.

You must say who you are first, and then you can ask for files.

§5References